【多代码慎入】Raspberry PI的日常

login as: pi
pi@192.168.137.108's password:
Access denied
pi@192.168.137.108's password:
Linux raspberrypi 3.18.5+ #744 PREEMPT Fri Jan 30 18:19:07 GMT 2015 armv6l

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.

NOTICE: the software on this Raspberry Pi has not been fully configured. Please run 'sudo raspi-config'

pi@raspberrypi ~ $ sudo raspi-config

Command (m for help):
Disk /dev/mmcblk0: 15.9 GB, 15931539456 bytes
4 heads, 16 sectors/track, 486192 cylinders, total 31116288 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00092fac

        Device Boot      Start         End      Blocks   Id  System
/dev/mmcblk0p1            8192      122879       57344    c  W95 FAT32 (LBA)
/dev/mmcblk0p2          122880     6399999     3138560   83  Linux

Command (m for help): Partition number (1-4):
Command (m for help): Partition type:
   p   primary (1 primary, 0 extended, 3 free)
   e   extended
Select (default p): Partition number (1-4, default 2): First sector (2048-31116287, default 2048): Last sector, +sectors or +size{K,M,G} (122880-31116287, default 31116287): Using default value 31116287

Command (m for help):
Disk /dev/mmcblk0: 15.9 GB, 15931539456 bytes
4 heads, 16 sectors/track, 486192 cylinders, total 31116288 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00092fac

        Device Boot      Start         End      Blocks   Id  System
/dev/mmcblk0p1            8192      122879       57344    c  W95 FAT32 (LBA)
/dev/mmcblk0p2          122880    31116287    15496704   83  Linux

Command (m for help): The partition table has been altered!

Calling ioctl() to re-read partition table.

WARNING: Re-reading the partition table failed with error 16: Device or resource busy.
The kernel still uses the old table. The new table will be used at
the next reboot or after you run partprobe(8) or kpartx(8)
Syncing disks.
update-rc.d: using dependency based boot sequencing
update-rc.d: warning: default start runlevel arguments (2 3 4 5) do not match resize2fs_once Default-Start values (2 3 4 5 S)
update-rc.d: warning: default stop runlevel arguments (0 1 6) do not match resize2fs_once Default-Stop values (none)
Enter new UNIX password:
Retype new UNIX password:
passwd: password updated successfully
update-rc.d: using dependency based boot sequencing

Current default time zone: 'US/Eastern'
Local time is now:      Sat Jan 31 18:02:31 EST 2015.
Universal Time is now:  Sat Jan 31 23:02:31 UTC 2015.

Generating locales (this might take a while)...
  en_US.UTF-8... done
  zh_CN.GB2312... done
  zh_CN.UTF-8... done
Generation complete.

Broadcast message from root@raspberrypi (pts/0) (Sat Jan 31 18:08:47 2015):
The system is going down for reboot NOW!
pi@raspberrypi ~ $
login as: pi
pi@192.168.137.108's password:
Linux raspberrypi 3.18.5+ #744 PREEMPT Fri Jan 30 18:19:07 GMT 2015 armv6l

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Sat Jan 31 18:01:27 2015 from deancyl-pc.mshome.net
pi@raspberrypi ~ $ sudo passwd
Enter new UNIX password:
Retype new UNIX password:
passwd: password updated successfully
pi@raspberrypi ~ $ sudo nano /etc/network/interfaces
pi@raspberrypi ~ $ sudo reboot

Broadcast message from root@raspberrypi (pts/0) (Sat Jan 31 18:11:24 2015):
The system is going down for reboot NOW!
pi@raspberrypi ~ $
login as: pi
pi@192.168.137.108's password:
Linux raspberrypi 3.18.5+ #744 PREEMPT Fri Jan 30 18:19:07 GMT 2015 armv6l

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Sat Jan 31 18:09:36 2015 from deancyl-pc.mshome.net
pi@raspberrypi ~ $ sudo apt-get update
Hit http://raspberrypi.collabora.com wheezy Release.gpg
Get:1 http://archive.raspberrypi.org wheezy Release.gpg [490 B]
Get:2 http://mirrordirector.raspbian.org wheezy Release.gpg [490 B]
Hit http://raspberrypi.collabora.com wheezy Release
Get:3 http://mirrordirector.raspbian.org wheezy Release [14.4 kB]
Get:4 http://archive.raspberrypi.org wheezy Release [10.2 kB]
Hit http://raspberrypi.collabora.com wheezy/rpi armhf Packages
Get:5 http://mirrordirector.raspbian.org wheezy/main armhf Packages [6896 kB]
Get:6 http://archive.raspberrypi.org wheezy/main armhf Packages [108 kB]
Ign http://raspberrypi.collabora.com wheezy/rpi Translation-en
Ign http://archive.raspberrypi.org wheezy/main Translation-en
Hit http://mirrordirector.raspbian.org wheezy/contrib armhf Packages
Hit http://mirrordirector.raspbian.org wheezy/non-free armhf Packages
Hit http://mirrordirector.raspbian.org wheezy/rpi armhf Packages
Ign http://mirrordirector.raspbian.org wheezy/contrib Translation-en
Ign http://mirrordirector.raspbian.org wheezy/main Translation-en
Ign http://mirrordirector.raspbian.org wheezy/non-free Translation-en
Ign http://mirrordirector.raspbian.org wheezy/rpi Translation-en
Fetched 7030 kB in 28s (248 kB/s)
Reading package lists... Done
pi@raspberrypi ~ $ #update
pi@raspberrypi ~ $
pi@raspberrypi ~ $ 3  0 Comments
dpkg: –purge needs at least one package name argument

dpkg安裝的可以用apt卸載,反之亦可。
-bash: 3: command not found

pi@raspberrypi ~ $
17
pi@raspberrypi ~ $
pi@raspberrypi ~ $ #Comments
pi@raspberrypi ~ $       apt-get install softname1 softname2 softname3
sudo apt-get build-dep # ------(package 安装相关的编译环境)
apt-get source #------(package 下载该包的源代码)
sudo apt-get clean && sudo apt-get autoclean # --------清理下载文件的存档 && 只清理过时的包
sudo apt-get check #-------检查是否有损坏的依赖
本文来自:树莓派实验室E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
pi@raspberrypi ~ $       apt-get remove softname1 softname2 softname3
E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
pi@raspberrypi ~ $  apt-get purge softname1remove
E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
pi@raspberrypi ~ $  apt-get update
E: Could not open lock file /var/lib/apt/lists/lock - open (13: Permission denied)
E: Unable to lock directory /var/lib/apt/lists/
E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
pi@raspberrypi ~ $  apt-get upgrade
E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
pi@raspberrypi ~ $  apt-cache search softname1 softname2 softname3
^C
pi@raspberrypi ~ $ sudo apt-get install lxmusic
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  libxmmsclient-glib1 libxmmsclient6 xmms2-core xmms2-plugin-alsa
  xmms2-plugin-id3v2 xmms2-plugin-mad xmms2-plugin-vorbis
Suggested packages:
  xmms2-plugin-all
The following NEW packages will be installed:
  libxmmsclient-glib1 libxmmsclient6 lxmusic xmms2-core xmms2-plugin-alsa
  xmms2-plugin-id3v2 xmms2-plugin-mad xmms2-plugin-vorbis
0 upgraded, 8 newly installed, 0 to remove and 25 not upgraded.
Need to get 857 kB of archives.
After this operation, 2515 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libxmmsclient6 armhf 0.8+dfsg-4+deb7u1 [67.2 kB]
Get:2 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libxmmsclient-glib1 armhf 0.8+dfsg-4+deb7u1 [18.4 kB]
Get:3 http://mirrordirector.raspbian.org/raspbian/ wheezy/main xmms2-core armhf 0.8+dfsg-4+deb7u1 [559 kB]
Get:4 http://mirrordirector.raspbian.org/raspbian/ wheezy/main lxmusic armhf 0.4.4+git20100802-3 [116 kB]
Get:5 http://mirrordirector.raspbian.org/raspbian/ wheezy/main xmms2-plugin-alsa armhf 0.8+dfsg-4+deb7u1 [22.7 kB]
Get:6 http://mirrordirector.raspbian.org/raspbian/ wheezy/main xmms2-plugin-id3v2 armhf 0.8+dfsg-4+deb7u1 [23.7 kB]
Get:7 http://mirrordirector.raspbian.org/raspbian/ wheezy/main xmms2-plugin-mad armhf 0.8+dfsg-4+deb7u1 [27.5 kB]
Get:8 http://mirrordirector.raspbian.org/raspbian/ wheezy/main xmms2-plugin-vorbis armhf 0.8+dfsg-4+deb7u1 [21.7 kB]
Fetched 857 kB in 1s (458 kB/s)
Selecting previously unselected package libxmmsclient6.
(Reading database ... 76913 files and directories currently installed.)
Unpacking libxmmsclient6 (from .../libxmmsclient6_0.8+dfsg-4+deb7u1_armhf.deb) ...
Selecting previously unselected package libxmmsclient-glib1.
Unpacking libxmmsclient-glib1 (from .../libxmmsclient-glib1_0.8+dfsg-4+deb7u1_armhf.deb) ...
Selecting previously unselected package xmms2-core.
Unpacking xmms2-core (from .../xmms2-core_0.8+dfsg-4+deb7u1_armhf.deb) ...
Selecting previously unselected package lxmusic.
Unpacking lxmusic (from .../lxmusic_0.4.4+git20100802-3_armhf.deb) ...
Selecting previously unselected package xmms2-plugin-alsa.
Unpacking xmms2-plugin-alsa (from .../xmms2-plugin-alsa_0.8+dfsg-4+deb7u1_armhf.deb) ...
Selecting previously unselected package xmms2-plugin-id3v2.
Unpacking xmms2-plugin-id3v2 (from .../xmms2-plugin-id3v2_0.8+dfsg-4+deb7u1_armhf.deb) ...
Selecting previously unselected package xmms2-plugin-mad.
Unpacking xmms2-plugin-mad (from .../xmms2-plugin-mad_0.8+dfsg-4+deb7u1_armhf.deb) ...
Selecting previously unselected package xmms2-plugin-vorbis.
Unpacking xmms2-plugin-vorbis (from .../xmms2-plugin-vorbis_0.8+dfsg-4+deb7u1_armhf.deb) ...
Processing triggers for man-db ...
Processing triggers for desktop-file-utils ...
Setting up libxmmsclient6 (0.8+dfsg-4+deb7u1) ...
Setting up libxmmsclient-glib1 (0.8+dfsg-4+deb7u1) ...
Setting up xmms2-core (0.8+dfsg-4+deb7u1) ...
Setting up lxmusic (0.4.4+git20100802-3) ...
Setting up xmms2-plugin-alsa (0.8+dfsg-4+deb7u1) ...
Setting up xmms2-plugin-id3v2 (0.8+dfsg-4+deb7u1) ...
Setting up xmms2-plugin-mad (0.8+dfsg-4+deb7u1) ...
Setting up xmms2-plugin-vorbis (0.8+dfsg-4+deb7u1) ...
pi@raspberrypi ~ $ sudo apt-get install tightvncserver
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  xfonts-base
Suggested packages:
  tightvnc-java
The following NEW packages will be installed:
  tightvncserver xfonts-base
0 upgraded, 2 newly installed, 0 to remove and 25 not upgraded.
Need to get 6967 kB of archives.
After this operation, 9988 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://mirrordirector.raspbian.org/raspbian/ wheezy/main tightvncserver armhf 1.3.9-6.4 [786 kB]
Get:2 http://mirrordirector.raspbian.org/raspbian/ wheezy/main xfonts-base all 1:1.0.3 [6181 kB]
Fetched 6967 kB in 3s (1877 kB/s)
Selecting previously unselected package tightvncserver.
(Reading database ... 77022 files and directories currently installed.)
Unpacking tightvncserver (from .../tightvncserver_1.3.9-6.4_armhf.deb) ...
Selecting previously unselected package xfonts-base.
Unpacking xfonts-base (from .../xfonts-base_1%3a1.0.3_all.deb) ...
Processing triggers for man-db ...
Processing triggers for fontconfig ...
Setting up tightvncserver (1.3.9-6.4) ...
update-alternatives: using /usr/bin/tightvncserver to provide /usr/bin/vncserver (vncserver) in auto mode
update-alternatives: using /usr/bin/Xtightvnc to provide /usr/bin/Xvnc (Xvnc) in auto mode
update-alternatives: using /usr/bin/tightvncpasswd to provide /usr/bin/vncpasswd (vncpasswd) in auto mode
Setting up xfonts-base (1:1.0.3) ...
pi@raspberrypi ~ $ vncserver :1 -geometry 1366x768

You will require a password to access your desktops.

Password:
Verify:
Would you like to enter a view-only password (y/n)? n

New 'X' desktop is raspberrypi:1

Creating default startup script /home/pi/.vnc/xstartup
Starting applications specified in /home/pi/.vnc/xstartup
Log file is /home/pi/.vnc/raspberrypi:1.log

pi@raspberrypi ~ $ ifconfig
eth0      Link encap:Ethernet  HWaddr b8:27:eb:17:f6:1f
          inet addr:192.168.137.108  Bcast:192.168.137.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:11132 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3108 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:15488067 (14.7 MiB)  TX bytes:318421 (310.9 KiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:8 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1104 (1.0 KiB)  TX bytes:1104 (1.0 KiB)

pi@raspberrypi ~ $ sudo su
root@raspberrypi:/home/pi# apt-get install bluetooth bluez-utils bluez-compat blueman
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  acl avahi-daemon bc bind9-host bluez bluez-alsa bluez-cups bluez-gstreamer
  colord cups cups-filters cups-ppdc dc foomatic-db-compressed-ppds
  foomatic-db-engine foomatic-filters geoip-database ghostscript-cups hpijs
  hplip hplip-data imagemagick-common libart-2.0-2 libavahi-core7 libbind9-80
  libcanberra-gtk3-0 libcanberra-gtk3-module libcanberra0 libcap-ng0
  libcupscgi1 libcupsdriver1 libcupsfilters1 libcupsmime1 libcupsppdc1
  libdns88 libescpr1 libgeoip1 libgusb2 libgutenprint2 libhpmud0 libieee1284-3
  libisc84 libisccc80 libisccfg82 liblqr-1-0 liblwres80 libmagickcore5
  libmagickwand5 libnss-mdns libopenobex1 libperl5.14 libpulse-mainloop-glib0
  libsane libsane-common libsane-extras libsane-extras-common libsane-hpaio
  libsensors4 libslp1 libsnmp-base libsnmp15 mscompress notification-daemon
  obex-data-server printer-driver-all printer-driver-c2050
  printer-driver-c2esp printer-driver-cjet printer-driver-escpr
  printer-driver-foo2zjs printer-driver-gutenprint printer-driver-hpcups
  printer-driver-hpijs printer-driver-m2300w printer-driver-min12xxw
  printer-driver-pnm2ppa printer-driver-postscript-hp printer-driver-ptouch
  printer-driver-pxljr printer-driver-sag-gdi printer-driver-splix
  python-cairo python-gconf python-gobject python-gobject-2 python-gtk2
  python-imaging python-notify python-pexpect python-renderpm python-reportlab
  python-reportlab-accel sane-utils ssl-cert
Suggested packages:
  avahi-autoipd cups-pdf hplip-cups openprinting-ppds cjet
  foomatic-db-gutenprint hplip-gui hplip-doc system-config-printer
  libcanberra-gtk0 libcanberra-pulse geoip-bin gutenprint-locales
  libmagickcore5-extra hpoj lm-sensors slpd openslp-doc snmp-mibs-downloader
  psutils hannah-foo2zjs tk8.4 tix gutenprint-doc hpijs-ppds magicfilter
  apsfilter python-gnome2-doc python-gobject-2-dbg python-gtk2-doc
  python-imaging-doc python-imaging-dbg python-renderpm-dbg
  python-egenix-mxtexttools python-reportlab-doc unpaper openssl-blacklist
Recommended packages:
  foomatic-db
The following NEW packages will be installed:
  acl avahi-daemon bc bind9-host blueman bluetooth bluez bluez-alsa
  bluez-compat bluez-cups bluez-gstreamer bluez-utils colord cups cups-filters
  cups-ppdc dc foomatic-db-compressed-ppds foomatic-db-engine foomatic-filters
  geoip-database ghostscript-cups hpijs hplip hplip-data imagemagick-common
  libart-2.0-2 libavahi-core7 libbind9-80 libcanberra-gtk3-0
  libcanberra-gtk3-module libcanberra0 libcap-ng0 libcupscgi1 libcupsdriver1
  libcupsfilters1 libcupsmime1 libcupsppdc1 libdns88 libescpr1 libgeoip1
  libgusb2 libgutenprint2 libhpmud0 libieee1284-3 libisc84 libisccc80
  libisccfg82 liblqr-1-0 liblwres80 libmagickcore5 libmagickwand5 libnss-mdns
  libopenobex1 libperl5.14 libpulse-mainloop-glib0 libsane libsane-common
  libsane-extras libsane-extras-common libsane-hpaio libsensors4 libslp1
  libsnmp-base libsnmp15 mscompress notification-daemon obex-data-server
  printer-driver-all printer-driver-c2050 printer-driver-c2esp
  printer-driver-cjet printer-driver-escpr printer-driver-foo2zjs
  printer-driver-gutenprint printer-driver-hpcups printer-driver-hpijs
  printer-driver-m2300w printer-driver-min12xxw printer-driver-pnm2ppa
  printer-driver-postscript-hp printer-driver-ptouch printer-driver-pxljr
  printer-driver-sag-gdi printer-driver-splix python-cairo python-gconf
  python-gobject python-gobject-2 python-gtk2 python-imaging python-notify
  python-pexpect python-renderpm python-reportlab python-reportlab-accel
  sane-utils ssl-cert
0 upgraded, 98 newly installed, 0 to remove and 25 not upgraded.
Need to get 34.7 MB of archives.
After this operation, 95.5 MB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://archive.raspberrypi.org/debian/ wheezy/main python-gobject all 3.8.2-1+rpi1rpi2 [242 kB]
Get:2 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libgusb2 armhf 0.1.3-5 [16.5 kB]
Get:3 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libsane-common armhf 1.0.22-7.4 [722 kB]
Get:4 http://mirrordirector.raspbian.org/raspbian/ wheezy/main acl armhf 2.2.51-8 [68.6 kB]
Get:5 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libieee1284-3 armhf 0.2.11-10 [27.9 kB]
Get:6 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libsane armhf 1.0.22-7.4 [1669 kB]
Get:7 http://mirrordirector.raspbian.org/raspbian/ wheezy/main colord armhf 0.1.21-1 [229 kB]
Get:8 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libcupscgi1 armhf 1.5.3-5+deb7u4 [114 kB]
Get:9 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libcupsmime1 armhf 1.5.3-5+deb7u4 [97.7 kB]
Get:10 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libcupsppdc1 armhf 1.5.3-5+deb7u4 [136 kB]
Get:11 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libslp1 armhf 1.2.1-9 [43.4 kB]
Get:12 http://mirrordirector.raspbian.org/raspbian/ wheezy/main ssl-cert all 1.0.32 [19.5 kB]
Get:13 http://mirrordirector.raspbian.org/raspbian/ wheezy/main bc armhf 1.06.95-2 [106 kB]
Get:14 http://mirrordirector.raspbian.org/raspbian/ wheezy/main cups-ppdc armhf 1.5.3-5+deb7u4 [115 kB]
Get:15 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libcupsfilters1 armhf 1.0.18-2.1+deb7u1 [61.4 kB]
Get:16 http://mirrordirector.raspbian.org/raspbian/ wheezy/main cups-filters armhf 1.0.18-2.1+deb7u1 [360 kB]
Get:17 http://mirrordirector.raspbian.org/raspbian/ wheezy/main cups armhf 1.5.3-5+deb7u4 [1398 kB]
Get:18 http://mirrordirector.raspbian.org/raspbian/ wheezy/main foomatic-filters armhf 4.0.17-1 [156 kB]
Get:19 http://mirrordirector.raspbian.org/raspbian/ wheezy/main foomatic-db-engine armhf 4.0.8-3 [315 kB]
Get:20 http://mirrordirector.raspbian.org/raspbian/ wheezy/main geoip-database all 20130213-1 [1466 kB]
Get:21 http://mirrordirector.raspbian.org/raspbian/ wheezy/main imagemagick-common all 8:6.7.7.10-5+deb7u3 [128 kB]
Get:22 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libart-2.0-2 armhf 2.3.21-2 [63.8 kB]
Get:23 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libavahi-core7 armhf 0.6.31-2 [119 kB]
Get:24 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libcanberra0 armhf 0.28-6 [36.6 kB]
Get:25 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libcanberra-gtk3-0 armhf 0.28-6 [14.2 kB]
Get:26 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libcupsdriver1 armhf 1.5.3-5+deb7u4 [105 kB]
Get:27 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libescpr1 armhf 1.1.1-2 [14.4 kB]
Get:28 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libgutenprint2 armhf 5.2.9-1 [1169 kB]
Get:29 http://mirrordirector.raspbian.org/raspbian/ wheezy/main liblqr-1-0 armhf 0.4.1-2 [26.6 kB]
Get:30 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libmagickcore5 armhf 8:6.7.7.10-5+deb7u3 [2096 kB]
Get:31 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libmagickwand5 armhf 8:6.7.7.10-5+deb7u3 [513 kB]
Get:32 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libpulse-mainloop-glib0 armhf 2.0-6.1 [24.3 kB]
Get:33 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libsensors4 armhf 1:3.3.2-2+deb7u1 [51.9 kB]
Get:34 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libgeoip1 armhf 1.4.8+dfsg-3 [133 kB]
Get:35 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libisc84 armhf 1:9.8.4.dfsg.P1-6+nmu2+deb7u3 [168 kB]
Get:36 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libdns88 armhf 1:9.8.4.dfsg.P1-6+nmu2+deb7u3 [708 kB]
Get:37 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libisccc80 armhf 1:9.8.4.dfsg.P1-6+nmu2+deb7u3 [32.8 kB]
Get:38 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libisccfg82 armhf 1:9.8.4.dfsg.P1-6+nmu2+deb7u3 [54.2 kB]
Get:39 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libbind9-80 armhf 1:9.8.4.dfsg.P1-6+nmu2+deb7u3 [41.1 kB]
Get:40 http://mirrordirector.raspbian.org/raspbian/ wheezy/main liblwres80 armhf 1:9.8.4.dfsg.P1-6+nmu2+deb7u3 [51.0 kB]
Get:41 http://mirrordirector.raspbian.org/raspbian/ wheezy/main bind9-host armhf 1:9.8.4.dfsg.P1-6+nmu2+deb7u3 [71.2 kB]
Get:42 http://mirrordirector.raspbian.org/raspbian/ wheezy/main dc armhf 1.06.95-2 [66.0 kB]
Get:43 http://mirrordirector.raspbian.org/raspbian/ wheezy/main avahi-daemon armhf 0.6.31-2 [94.2 kB]
Get:44 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libcap-ng0 armhf 0.6.6-2 [12.3 kB]
Get:45 http://mirrordirector.raspbian.org/raspbian/ wheezy/main bluez armhf 4.99-2 [895 kB]
Get:46 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libopenobex1 armhf 1.5-2+deb7u1 [21.3 kB]
Get:47 http://mirrordirector.raspbian.org/raspbian/ wheezy/main obex-data-server armhf 0.4.5-1 [89.0 kB]
Get:48 http://mirrordirector.raspbian.org/raspbian/ wheezy/main python-cairo armhf 1.8.8-1 [68.6 kB]
Get:49 http://mirrordirector.raspbian.org/raspbian/ wheezy/main python-gobject-2 armhf 2.28.6-10 [475 kB]
Get:50 http://mirrordirector.raspbian.org/raspbian/ wheezy/main python-gtk2 armhf 2.24.0-3 [1450 kB]
Get:51 http://mirrordirector.raspbian.org/raspbian/ wheezy/main python-notify armhf 0.1.1-3 [17.9 kB]
Get:52 http://mirrordirector.raspbian.org/raspbian/ wheezy/main notification-daemon armhf 0.7.6-1 [49.0 kB]
Get:53 http://mirrordirector.raspbian.org/raspbian/ wheezy/main blueman armhf 1.23-1 [578 kB]
Get:54 http://mirrordirector.raspbian.org/raspbian/ wheezy/main bluetooth all 4.99-2 [37.5 kB]
Get:55 http://mirrordirector.raspbian.org/raspbian/ wheezy/main bluez-alsa armhf 4.99-2 [161 kB]
Get:56 http://mirrordirector.raspbian.org/raspbian/ wheezy/main bluez-compat armhf 4.99-2 [182 kB]
Get:57 http://mirrordirector.raspbian.org/raspbian/ wheezy/main bluez-cups armhf 4.99-2 [88.4 kB]
Get:58 http://mirrordirector.raspbian.org/raspbian/ wheezy/main bluez-gstreamer armhf 4.99-2 [139 kB]
Get:59 http://mirrordirector.raspbian.org/raspbian/ wheezy/main bluez-utils all 4.99-2 [37.4 kB]
Get:60 http://mirrordirector.raspbian.org/raspbian/ wheezy/main foomatic-db-compressed-ppds all 20120523-1 [667 kB]
Get:61 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libperl5.14 armhf 5.14.2-21+rpi2+deb7u2 [1204 B]
Get:62 http://mirrordirector.raspbian.org/raspbian/ wheezy/main ghostscript-cups armhf 9.05~dfsg-6.3+deb7u1 [59.0 kB]
Get:63 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libsnmp-base all 5.4.3~dfsg-2.8+deb7u1 [1100 kB]
Get:64 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libsnmp15 armhf 5.4.3~dfsg-2.8+deb7u1 [2160 kB]
Get:65 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libhpmud0 armhf 3.12.6-3.1+deb7u1 [165 kB]
Get:66 http://mirrordirector.raspbian.org/raspbian/ wheezy/main printer-driver-hpijs armhf 3.12.6-3.1+deb7u1 [402 kB]
Get:67 http://mirrordirector.raspbian.org/raspbian/ wheezy/main hpijs all 3.12.6-3.1+deb7u1 [72.6 kB]
Get:68 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libsane-hpaio armhf 3.12.6-3.1+deb7u1 [198 kB]
Get:69 http://mirrordirector.raspbian.org/raspbian/ wheezy/main hplip-data all 3.12.6-3.1+deb7u1 [6870 kB]
Get:70 http://mirrordirector.raspbian.org/raspbian/ wheezy/main printer-driver-all all 0.20120416 [1964 B]
Get:71 http://mirrordirector.raspbian.org/raspbian/ wheezy/main printer-driver-hpcups armhf 3.12.6-3.1+deb7u1 [369 kB]
Get:72 http://mirrordirector.raspbian.org/raspbian/ wheezy/main python-imaging armhf 1.1.7-4+deb7u1 [413 kB]
Get:73 http://mirrordirector.raspbian.org/raspbian/ wheezy/main python-pexpect all 2.4-1 [123 kB]
Get:74 http://mirrordirector.raspbian.org/raspbian/ wheezy/main python-reportlab all 2.5-1.1 [572 kB]
Get:75 http://mirrordirector.raspbian.org/raspbian/ wheezy/main hplip armhf 3.12.6-3.1+deb7u1 [152 kB]
Get:76 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libcanberra-gtk3-module armhf 0.28-6 [16.1 kB]
Get:77 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libnss-mdns armhf 0.10-3.2 [23.7 kB]
Get:78 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libsane-extras-common armhf 1.0.22.2 [12.5 kB]
Get:79 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libsane-extras armhf 1.0.22.2 [59.0 kB]
Get:80 http://mirrordirector.raspbian.org/raspbian/ wheezy/main printer-driver-c2050 armhf 0.3b-4 [11.0 kB]
Get:81 http://mirrordirector.raspbian.org/raspbian/ wheezy/main printer-driver-c2esp armhf 24-2 [32.3 kB]
Get:82 http://mirrordirector.raspbian.org/raspbian/ wheezy/main printer-driver-cjet armhf 0.8.9-3 [24.0 kB]
Get:83 http://mirrordirector.raspbian.org/raspbian/ wheezy/main printer-driver-escpr armhf 1.1.1-2 [70.9 kB]
Get:84 http://mirrordirector.raspbian.org/raspbian/ wheezy/main printer-driver-foo2zjs armhf 20120510dfsg0-1 [1135 kB]
Get:85 http://mirrordirector.raspbian.org/raspbian/ wheezy/main printer-driver-gutenprint armhf 5.2.9-1 [420 kB]
Get:86 http://mirrordirector.raspbian.org/raspbian/ wheezy/main printer-driver-m2300w armhf 0.51-7 [503 kB]
Get:87 http://mirrordirector.raspbian.org/raspbian/ wheezy/main printer-driver-min12xxw armhf 0.0.9-6 [48.5 kB]
Get:88 http://mirrordirector.raspbian.org/raspbian/ wheezy/main printer-driver-pnm2ppa armhf 1.13-4 [220 kB]
Get:89 http://mirrordirector.raspbian.org/raspbian/ wheezy/main printer-driver-postscript-hp all 3.12.6-3.1+deb7u1 [895 kB]
Get:90 http://mirrordirector.raspbian.org/raspbian/ wheezy/main printer-driver-ptouch armhf 1.3-4 [30.2 kB]
Get:91 http://mirrordirector.raspbian.org/raspbian/ wheezy/main printer-driver-pxljr armhf 1.3+repack0-2 [29.9 kB]
Get:92 http://mirrordirector.raspbian.org/raspbian/ wheezy/main printer-driver-sag-gdi all 0.1-3 [8854 B]
Get:93 http://mirrordirector.raspbian.org/raspbian/ wheezy/main printer-driver-splix armhf 2.0.0+svn306-2 [43.9 kB]
Get:94 http://mirrordirector.raspbian.org/raspbian/ wheezy/main python-gconf armhf 2.28.1+dfsg-1 [75.7 kB]
Get:95 http://mirrordirector.raspbian.org/raspbian/ wheezy/main python-renderpm armhf 2.5-1.1 [61.9 kB]
Get:96 http://mirrordirector.raspbian.org/raspbian/ wheezy/main python-reportlab-accel armhf 2.5-1.1 [56.9 kB]
Get:97 http://mirrordirector.raspbian.org/raspbian/ wheezy/main sane-utils armhf 1.0.22-7.4 [185 kB]
Get:98 http://mirrordirector.raspbian.org/raspbian/ wheezy/main mscompress armhf 0.3-4 [8698 B]
Fetched 34.7 MB in 24s (1427 kB/s)
Extracting templates from packages: 100%
Preconfiguring packages ...
Selecting previously unselected package libgusb2.
(Reading database ... 77457 files and directories currently installed.)
Unpacking libgusb2 (from .../libgusb2_0.1.3-5_armhf.deb) ...
Selecting previously unselected package libsane-common.
Unpacking libsane-common (from .../libsane-common_1.0.22-7.4_armhf.deb) ...
Selecting previously unselected package acl.
Unpacking acl (from .../acl_2.2.51-8_armhf.deb) ...
Selecting previously unselected package libieee1284-3:armhf.
Unpacking libieee1284-3:armhf (from .../libieee1284-3_0.2.11-10_armhf.deb) ...
Selecting previously unselected package libsane:armhf.
Unpacking libsane:armhf (from .../libsane_1.0.22-7.4_armhf.deb) ...
Selecting previously unselected package colord.
Unpacking colord (from .../colord_0.1.21-1_armhf.deb) ...
Selecting previously unselected package libcupscgi1:armhf.
Unpacking libcupscgi1:armhf (from .../libcupscgi1_1.5.3-5+deb7u4_armhf.deb) ...
Selecting previously unselected package libcupsmime1:armhf.
Unpacking libcupsmime1:armhf (from .../libcupsmime1_1.5.3-5+deb7u4_armhf.deb) ...
Selecting previously unselected package libcupsppdc1:armhf.
Unpacking libcupsppdc1:armhf (from .../libcupsppdc1_1.5.3-5+deb7u4_armhf.deb) ...
Selecting previously unselected package libslp1.
Unpacking libslp1 (from .../libslp1_1.2.1-9_armhf.deb) ...
Selecting previously unselected package ssl-cert.
Unpacking ssl-cert (from .../ssl-cert_1.0.32_all.deb) ...
Selecting previously unselected package bc.
Unpacking bc (from .../bc_1.06.95-2_armhf.deb) ...
Selecting previously unselected package cups-ppdc.
Unpacking cups-ppdc (from .../cups-ppdc_1.5.3-5+deb7u4_armhf.deb) ...
Selecting previously unselected package libcupsfilters1:armhf.
Unpacking libcupsfilters1:armhf (from .../libcupsfilters1_1.0.18-2.1+deb7u1_armhf.deb) ...
Selecting previously unselected package cups-filters.
Unpacking cups-filters (from .../cups-filters_1.0.18-2.1+deb7u1_armhf.deb) ...
Selecting previously unselected package cups.
Unpacking cups (from .../cups_1.5.3-5+deb7u4_armhf.deb) ...
Selecting previously unselected package foomatic-filters.
Unpacking foomatic-filters (from .../foomatic-filters_4.0.17-1_armhf.deb) ...
Selecting previously unselected package foomatic-db-engine.
Unpacking foomatic-db-engine (from .../foomatic-db-engine_4.0.8-3_armhf.deb) ...
Selecting previously unselected package geoip-database.
Unpacking geoip-database (from .../geoip-database_20130213-1_all.deb) ...
Selecting previously unselected package imagemagick-common.
Unpacking imagemagick-common (from .../imagemagick-common_8%3a6.7.7.10-5+deb7u3_all.deb) ...
Selecting previously unselected package libart-2.0-2:armhf.
Unpacking libart-2.0-2:armhf (from .../libart-2.0-2_2.3.21-2_armhf.deb) ...
Selecting previously unselected package libavahi-core7:armhf.
Unpacking libavahi-core7:armhf (from .../libavahi-core7_0.6.31-2_armhf.deb) ...
Selecting previously unselected package libcanberra0:armhf.
Unpacking libcanberra0:armhf (from .../libcanberra0_0.28-6_armhf.deb) ...
Selecting previously unselected package libcanberra-gtk3-0:armhf.
Unpacking libcanberra-gtk3-0:armhf (from .../libcanberra-gtk3-0_0.28-6_armhf.deb) ...
Selecting previously unselected package libcupsdriver1:armhf.
Unpacking libcupsdriver1:armhf (from .../libcupsdriver1_1.5.3-5+deb7u4_armhf.deb) ...
Selecting previously unselected package libescpr1:armhf.
Unpacking libescpr1:armhf (from .../libescpr1_1.1.1-2_armhf.deb) ...
Selecting previously unselected package libgutenprint2.
Unpacking libgutenprint2 (from .../libgutenprint2_5.2.9-1_armhf.deb) ...
Selecting previously unselected package liblqr-1-0:armhf.
Unpacking liblqr-1-0:armhf (from .../liblqr-1-0_0.4.1-2_armhf.deb) ...
Selecting previously unselected package libmagickcore5:armhf.
Unpacking libmagickcore5:armhf (from .../libmagickcore5_8%3a6.7.7.10-5+deb7u3_armhf.deb) ...
Selecting previously unselected package libmagickwand5:armhf.
Unpacking libmagickwand5:armhf (from .../libmagickwand5_8%3a6.7.7.10-5+deb7u3_armhf.deb) ...
Selecting previously unselected package libpulse-mainloop-glib0:armhf.
Unpacking libpulse-mainloop-glib0:armhf (from .../libpulse-mainloop-glib0_2.0-6.1_armhf.deb) ...
Selecting previously unselected package libsensors4:armhf.
Unpacking libsensors4:armhf (from .../libsensors4_1%3a3.3.2-2+deb7u1_armhf.deb) ...
Selecting previously unselected package libgeoip1.
Unpacking libgeoip1 (from .../libgeoip1_1.4.8+dfsg-3_armhf.deb) ...
Selecting previously unselected package libisc84.
Unpacking libisc84 (from .../libisc84_1%3a9.8.4.dfsg.P1-6+nmu2+deb7u3_armhf.deb) ...
Selecting previously unselected package libdns88.
Unpacking libdns88 (from .../libdns88_1%3a9.8.4.dfsg.P1-6+nmu2+deb7u3_armhf.deb) ...
Selecting previously unselected package libisccc80.
Unpacking libisccc80 (from .../libisccc80_1%3a9.8.4.dfsg.P1-6+nmu2+deb7u3_armhf.deb) ...
Selecting previously unselected package libisccfg82.
Unpacking libisccfg82 (from .../libisccfg82_1%3a9.8.4.dfsg.P1-6+nmu2+deb7u3_armhf.deb) ...
Selecting previously unselected package libbind9-80.
Unpacking libbind9-80 (from .../libbind9-80_1%3a9.8.4.dfsg.P1-6+nmu2+deb7u3_armhf.deb) ...
Selecting previously unselected package liblwres80.
Unpacking liblwres80 (from .../liblwres80_1%3a9.8.4.dfsg.P1-6+nmu2+deb7u3_armhf.deb) ...
Selecting previously unselected package bind9-host.
Unpacking bind9-host (from .../bind9-host_1%3a9.8.4.dfsg.P1-6+nmu2+deb7u3_armhf.deb) ...
Selecting previously unselected package dc.
Unpacking dc (from .../dc_1.06.95-2_armhf.deb) ...
Selecting previously unselected package avahi-daemon.
Unpacking avahi-daemon (from .../avahi-daemon_0.6.31-2_armhf.deb) ...
Selecting previously unselected package libcap-ng0.
Unpacking libcap-ng0 (from .../libcap-ng0_0.6.6-2_armhf.deb) ...
Selecting previously unselected package bluez.
Unpacking bluez (from .../bluez_4.99-2_armhf.deb) ...
Selecting previously unselected package libopenobex1.
Unpacking libopenobex1 (from .../libopenobex1_1.5-2+deb7u1_armhf.deb) ...
Selecting previously unselected package obex-data-server.
Unpacking obex-data-server (from .../obex-data-server_0.4.5-1_armhf.deb) ...
Selecting previously unselected package python-cairo.
Unpacking python-cairo (from .../python-cairo_1.8.8-1_armhf.deb) ...
Selecting previously unselected package python-gobject-2.
Unpacking python-gobject-2 (from .../python-gobject-2_2.28.6-10_armhf.deb) ...
Selecting previously unselected package python-gtk2.
Unpacking python-gtk2 (from .../python-gtk2_2.24.0-3_armhf.deb) ...
Selecting previously unselected package python-notify.
Unpacking python-notify (from .../python-notify_0.1.1-3_armhf.deb) ...
Selecting previously unselected package notification-daemon.
Unpacking notification-daemon (from .../notification-daemon_0.7.6-1_armhf.deb) ...
Selecting previously unselected package blueman.
Unpacking blueman (from .../blueman_1.23-1_armhf.deb) ...
Selecting previously unselected package bluetooth.
Unpacking bluetooth (from .../bluetooth_4.99-2_all.deb) ...
Selecting previously unselected package bluez-alsa:armhf.
Unpacking bluez-alsa:armhf (from .../bluez-alsa_4.99-2_armhf.deb) ...
Selecting previously unselected package bluez-compat.
Unpacking bluez-compat (from .../bluez-compat_4.99-2_armhf.deb) ...
Selecting previously unselected package bluez-cups.
Unpacking bluez-cups (from .../bluez-cups_4.99-2_armhf.deb) ...
Selecting previously unselected package bluez-gstreamer.
Unpacking bluez-gstreamer (from .../bluez-gstreamer_4.99-2_armhf.deb) ...
Selecting previously unselected package bluez-utils.
Unpacking bluez-utils (from .../bluez-utils_4.99-2_all.deb) ...
Selecting previously unselected package foomatic-db-compressed-ppds.
Unpacking foomatic-db-compressed-ppds (from .../foomatic-db-compressed-ppds_20120523-1_all.deb) ...
Selecting previously unselected package ghostscript-cups.
Unpacking ghostscript-cups (from .../ghostscript-cups_9.05~dfsg-6.3+deb7u1_armhf.deb) ...
Selecting previously unselected package libsnmp-base.
Unpacking libsnmp-base (from .../libsnmp-base_5.4.3~dfsg-2.8+deb7u1_all.deb) ...
Selecting previously unselected package libperl5.14.
Unpacking libperl5.14 (from .../libperl5.14_5.14.2-21+rpi2+deb7u2_armhf.deb) ...
Selecting previously unselected package libsnmp15.
Unpacking libsnmp15 (from .../libsnmp15_5.4.3~dfsg-2.8+deb7u1_armhf.deb) ...
Selecting previously unselected package libhpmud0.
Unpacking libhpmud0 (from .../libhpmud0_3.12.6-3.1+deb7u1_armhf.deb) ...
Selecting previously unselected package printer-driver-hpijs.
Unpacking printer-driver-hpijs (from .../printer-driver-hpijs_3.12.6-3.1+deb7u1_armhf.deb) ...
Selecting previously unselected package hpijs.
Unpacking hpijs (from .../hpijs_3.12.6-3.1+deb7u1_all.deb) ...
Selecting previously unselected package libsane-hpaio.
Unpacking libsane-hpaio (from .../libsane-hpaio_3.12.6-3.1+deb7u1_armhf.deb) ...
Selecting previously unselected package hplip-data.
Unpacking hplip-data (from .../hplip-data_3.12.6-3.1+deb7u1_all.deb) ...
Selecting previously unselected package printer-driver-hpcups.
Unpacking printer-driver-hpcups (from .../printer-driver-hpcups_3.12.6-3.1+deb7u1_armhf.deb) ...
Selecting previously unselected package python-imaging.
Unpacking python-imaging (from .../python-imaging_1.1.7-4+deb7u1_armhf.deb) ...
Selecting previously unselected package python-pexpect.
Unpacking python-pexpect (from .../python-pexpect_2.4-1_all.deb) ...
Selecting previously unselected package python-reportlab.
Unpacking python-reportlab (from .../python-reportlab_2.5-1.1_all.deb) ...
Selecting previously unselected package hplip.
Unpacking hplip (from .../hplip_3.12.6-3.1+deb7u1_armhf.deb) ...
Selecting previously unselected package libcanberra-gtk3-module:armhf.
Unpacking libcanberra-gtk3-module:armhf (from .../libcanberra-gtk3-module_0.28-6_armhf.deb) ...
Selecting previously unselected package libnss-mdns.
Unpacking libnss-mdns (from .../libnss-mdns_0.10-3.2_armhf.deb) ...
Selecting previously unselected package libsane-extras-common.
Unpacking libsane-extras-common (from .../libsane-extras-common_1.0.22.2_armhf.deb) ...
Selecting previously unselected package libsane-extras:armhf.
Unpacking libsane-extras:armhf (from .../libsane-extras_1.0.22.2_armhf.deb) ...
Selecting previously unselected package printer-driver-all.
Unpacking printer-driver-all (from .../printer-driver-all_0.20120416_all.deb) ...
Selecting previously unselected package printer-driver-c2050.
Unpacking printer-driver-c2050 (from .../printer-driver-c2050_0.3b-4_armhf.deb) ...
Selecting previously unselected package printer-driver-c2esp.
Unpacking printer-driver-c2esp (from .../printer-driver-c2esp_24-2_armhf.deb) ...
Selecting previously unselected package printer-driver-cjet.
Unpacking printer-driver-cjet (from .../printer-driver-cjet_0.8.9-3_armhf.deb) ...
Selecting previously unselected package printer-driver-escpr.
Unpacking printer-driver-escpr (from .../printer-driver-escpr_1.1.1-2_armhf.deb) ...
Selecting previously unselected package printer-driver-foo2zjs.
Unpacking printer-driver-foo2zjs (from .../printer-driver-foo2zjs_20120510dfsg0-1_armhf.deb) ...
Selecting previously unselected package printer-driver-gutenprint.
Unpacking printer-driver-gutenprint (from .../printer-driver-gutenprint_5.2.9-1_armhf.deb) ...
Selecting previously unselected package printer-driver-m2300w.
Unpacking printer-driver-m2300w (from .../printer-driver-m2300w_0.51-7_armhf.deb) ...
Selecting previously unselected package printer-driver-min12xxw.
Unpacking printer-driver-min12xxw (from .../printer-driver-min12xxw_0.0.9-6_armhf.deb) ...
Selecting previously unselected package printer-driver-pnm2ppa.
Unpacking printer-driver-pnm2ppa (from .../printer-driver-pnm2ppa_1.13-4_armhf.deb) ...
Selecting previously unselected package printer-driver-postscript-hp.
Unpacking printer-driver-postscript-hp (from .../printer-driver-postscript-hp_3.12.6-3.1+deb7u1_all.deb) ...
Selecting previously unselected package printer-driver-ptouch.
Unpacking printer-driver-ptouch (from .../printer-driver-ptouch_1.3-4_armhf.deb) ...
Selecting previously unselected package printer-driver-pxljr.
Unpacking printer-driver-pxljr (from .../printer-driver-pxljr_1.3+repack0-2_armhf.deb) ...
Selecting previously unselected package printer-driver-sag-gdi.
Unpacking printer-driver-sag-gdi (from .../printer-driver-sag-gdi_0.1-3_all.deb) ...
Selecting previously unselected package printer-driver-splix.
Unpacking printer-driver-splix (from .../printer-driver-splix_2.0.0+svn306-2_armhf.deb) ...
Selecting previously unselected package python-gconf.
Unpacking python-gconf (from .../python-gconf_2.28.1+dfsg-1_armhf.deb) ...
Selecting previously unselected package python-renderpm.
Unpacking python-renderpm (from .../python-renderpm_2.5-1.1_armhf.deb) ...
Selecting previously unselected package python-reportlab-accel.
Unpacking python-reportlab-accel (from .../python-reportlab-accel_2.5-1.1_armhf.deb) ...
Selecting previously unselected package sane-utils.
Unpacking sane-utils (from .../sane-utils_1.0.22-7.4_armhf.deb) ...
Selecting previously unselected package mscompress.
Unpacking mscompress (from .../mscompress_0.3-4_armhf.deb) ...
Selecting previously unselected package python-gobject.
Unpacking python-gobject (from .../python-gobject_3.8.2-1+rpi1rpi2_all.deb) ...
Processing triggers for man-db ...
Processing triggers for menu ...
Processing triggers for install-info ...
Processing triggers for desktop-file-utils ...
Processing triggers for hicolor-icon-theme ...
Processing triggers for gconf2 ...
Setting up libgusb2 (0.1.3-5) ...
Setting up libsane-common (1.0.22-7.4) ...
Setting up acl (2.2.51-8) ...
Setting up libieee1284-3:armhf (0.2.11-10) ...
Setting up libsane:armhf (1.0.22-7.4) ...
Adding scanner group...
/run/udev or .udevdb or .udev presence implies active udev.  Aborting MAKEDEV invocation.
/run/udev or .udevdb or .udev presence implies active udev.  Aborting MAKEDEV invocation.
Setting up colord (0.1.21-1) ...
adduser: Warning: The home directory `/var/lib/colord' does not belong to the user you are currently creating.
Setting up libcupscgi1:armhf (1.5.3-5+deb7u4) ...
Setting up libcupsmime1:armhf (1.5.3-5+deb7u4) ...
Setting up libcupsppdc1:armhf (1.5.3-5+deb7u4) ...
Setting up libslp1 (1.2.1-9) ...
Setting up ssl-cert (1.0.32) ...
Setting up bc (1.06.95-2) ...
Setting up cups-ppdc (1.5.3-5+deb7u4) ...
Setting up libcupsfilters1:armhf (1.0.18-2.1+deb7u1) ...
Setting up cups-filters (1.0.18-2.1+deb7u1) ...
Setting up cups (1.5.3-5+deb7u4) ...
[ ok ] Starting Common Unix Printing System: cupsd.
Updating PPD files for cups ...
Updating PPD files for cups-filters ...
Updating PPD files for foomatic-db-compressed-ppds ...
Updating PPD files for foomatic-db-engine ...
Updating PPD files for ghostscript-cups ...
Updating PPD files for c2esp ...
Updating PPD files for escpr ...
Updating PPD files for foo2zjs ...
Updating PPD files for hpcups ...
Updating PPD files for hpijs ...
Updating PPD files for m2300w ...
Updating PPD files for postscript-hp ...
Updating PPD files for ptouch ...
Updating PPD files for pxljr ...
Updating PPD files for sag-gdi ...
Updating PPD files for splix ...
Setting up foomatic-filters (4.0.17-1) ...

Creating config file /etc/foomatic/filter.conf with new version
Setting up foomatic-db-engine (4.0.8-3) ...
Setting up geoip-database (20130213-1) ...
Setting up imagemagick-common (8:6.7.7.10-5+deb7u3) ...
Setting up libart-2.0-2:armhf (2.3.21-2) ...
Setting up libavahi-core7:armhf (0.6.31-2) ...
Setting up libcanberra0:armhf (0.28-6) ...
Setting up libcanberra-gtk3-0:armhf (0.28-6) ...
Setting up libcupsdriver1:armhf (1.5.3-5+deb7u4) ...
Setting up libescpr1:armhf (1.1.1-2) ...
Setting up libgutenprint2 (5.2.9-1) ...
Setting up liblqr-1-0:armhf (0.4.1-2) ...
Setting up libmagickcore5:armhf (8:6.7.7.10-5+deb7u3) ...
Setting up libmagickwand5:armhf (8:6.7.7.10-5+deb7u3) ...
Setting up libpulse-mainloop-glib0:armhf (2.0-6.1) ...
Setting up libsensors4:armhf (1:3.3.2-2+deb7u1) ...
Setting up libgeoip1 (1.4.8+dfsg-3) ...
Setting up libisc84 (1:9.8.4.dfsg.P1-6+nmu2+deb7u3) ...
Setting up libdns88 (1:9.8.4.dfsg.P1-6+nmu2+deb7u3) ...
Setting up libisccc80 (1:9.8.4.dfsg.P1-6+nmu2+deb7u3) ...
Setting up libisccfg82 (1:9.8.4.dfsg.P1-6+nmu2+deb7u3) ...
Setting up libbind9-80 (1:9.8.4.dfsg.P1-6+nmu2+deb7u3) ...
Setting up liblwres80 (1:9.8.4.dfsg.P1-6+nmu2+deb7u3) ...
Setting up bind9-host (1:9.8.4.dfsg.P1-6+nmu2+deb7u3) ...
Setting up dc (1.06.95-2) ...
Setting up avahi-daemon (0.6.31-2) ...
[ ok ] Reloading system message bus config...done.
[ ok ] Starting Avahi mDNS/DNS-SD Daemon: avahi-daemon.
Setting up libcap-ng0 (0.6.6-2) ...
Setting up bluez (4.99-2) ...
[ ok ] Reloading system message bus config...done.
[ ok ] Starting bluetooth: bluetoothd rfcomm.
Setting up libopenobex1 (1.5-2+deb7u1) ...
Setting up obex-data-server (0.4.5-1) ...
Setting up python-cairo (1.8.8-1) ...
Setting up python-gobject-2 (2.28.6-10) ...
Setting up python-gtk2 (2.24.0-3) ...
Setting up python-notify (0.1.1-3) ...
Setting up notification-daemon (0.7.6-1) ...
Setting up blueman (1.23-1) ...
[ ok ] Reloading system message bus config...done.
Setting up bluetooth (4.99-2) ...
Setting up bluez-alsa:armhf (4.99-2) ...
Setting up bluez-compat (4.99-2) ...
Setting up bluez-cups (4.99-2) ...
Setting up bluez-gstreamer (4.99-2) ...
Setting up bluez-utils (4.99-2) ...
Setting up foomatic-db-compressed-ppds (20120523-1) ...
Setting up ghostscript-cups (9.05~dfsg-6.3+deb7u1) ...
Setting up libsnmp-base (5.4.3~dfsg-2.8+deb7u1) ...
Setting up libperl5.14 (5.14.2-21+rpi2+deb7u2) ...
Setting up libsnmp15 (5.4.3~dfsg-2.8+deb7u1) ...
Setting up libhpmud0 (3.12.6-3.1+deb7u1) ...
Setting up printer-driver-hpijs (3.12.6-3.1+deb7u1) ...
Setting up hpijs (3.12.6-3.1+deb7u1) ...
Setting up libsane-hpaio (3.12.6-3.1+deb7u1) ...
Setting up hplip-data (3.12.6-3.1+deb7u1) ...
Setting up printer-driver-hpcups (3.12.6-3.1+deb7u1) ...
Setting up python-imaging (1.1.7-4+deb7u1) ...
Setting up python-pexpect (2.4-1) ...
Setting up python-reportlab (2.5-1.1) ...
Setting up hplip (3.12.6-3.1+deb7u1) ...
Creating/updating hplip user account...
update-rc.d: using dependency based boot sequencing
Setting up libcanberra-gtk3-module:armhf (0.28-6) ...
Setting up libnss-mdns (0.10-3.2) ...
First installation detected...
Checking NSS setup...
Setting up libsane-extras-common (1.0.22.2) ...
Setting up libsane-extras:armhf (1.0.22.2) ...
Setting up printer-driver-all (0.20120416) ...
Setting up printer-driver-c2050 (0.3b-4) ...
Setting up printer-driver-c2esp (24-2) ...
Setting up printer-driver-cjet (0.8.9-3) ...
Setting up printer-driver-escpr (1.1.1-2) ...
Setting up printer-driver-foo2zjs (20120510dfsg0-1) ...
Setting up printer-driver-gutenprint (5.2.9-1) ...
No Gutenprint PPD files to update.
[ ok ] Reloading Common Unix Printing System: cupsd.
Setting up printer-driver-m2300w (0.51-7) ...
Setting up printer-driver-min12xxw (0.0.9-6) ...
Setting up printer-driver-pnm2ppa (1.13-4) ...
Setting up printer-driver-postscript-hp (3.12.6-3.1+deb7u1) ...
Setting up printer-driver-ptouch (1.3-4) ...
Setting up printer-driver-pxljr (1.3+repack0-2) ...
Setting up printer-driver-sag-gdi (0.1-3) ...
Setting up printer-driver-splix (2.0.0+svn306-2) ...
Setting up python-gconf (2.28.1+dfsg-1) ...
Setting up python-renderpm (2.5-1.1) ...
Setting up python-reportlab-accel (2.5-1.1) ...
Setting up sane-utils (1.0.22-7.4) ...
Adding saned group and user...
Adding user saned to group scanner
saned disabled; edit /etc/default/saned
Setting up mscompress (0.3-4) ...
Setting up python-gobject (3.8.2-1+rpi1rpi2) ...
Processing triggers for menu ...
Processing triggers for python-support ...
root@raspberrypi:/home/pi# exit
exit
pi@raspberrypi ~ $ ls
Desktop  python_games
pi@raspberrypi ~ $ cd Desktop
pi@raspberrypi ~/Desktop $ ls
rpi-clone.sh
pi@raspberrypi ~/Desktop $ sudo fdisk -l

Disk /dev/mmcblk0: 15.9 GB, 15931539456 bytes
4 heads, 16 sectors/track, 486192 cylinders, total 31116288 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00092fac

        Device Boot      Start         End      Blocks   Id  System
/dev/mmcblk0p1            8192      122879       57344    c  W95 FAT32 (LBA)
/dev/mmcblk0p2          122880    31116287    15496704   83  Linux

Disk /dev/sda: 15.6 GB, 15552479232 bytes
255 heads, 63 sectors/track, 1890 cylinders, total 30375936 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1            8192    30375935    15183872    c  W95 FAT32 (LBA)
pi@raspberrypi ~/Desktop $ chmod +x rpi-clone.sh
pi@raspberrypi ~/Desktop $ sudo ./rpi_clone sda -f
sudo: ./rpi_clone: command not found
pi@raspberrypi ~/Desktop $ sudo sh rpi-clone.sh

usage: rpi-clone.sh sdN {-f|--force-initialize} {-v|--verbose}
    Example:  rpi-clone.sh sda
    -v - list all files as they are copied.
    -f - force initialize the destination partitions

    Clone (rsync) a running Raspberry Pi file system to a destination
    SD card 'sdN' plugged into a Pi USB port (via a USB card reader).
    rpi-clone.sh can clone the running system to a new SD card or can
    incrementally rsync to existing backup Raspberry Pi SD cards.

    If the destination SD card has an existing fat16 partition 1 and a
    ext4 partition 2, rpi-clone.sh assumes (unless using the -f option)
    that the SD card is an existing backup with the partitions
    properly sized and set up for a Raspberry Pi.  All that is needed
    is to mount the partitions and rsync them to the running system.

    If these partitions are not found (or -f), then rpi-clone.sh will ask
    if it is OK to initialize the destination SD card partitions.
    This is done by a partial 'dd' from the running booted device
    /dev/mmcblk0 to the destination SD card /dev/sdN followed by a
    fdisk resize and mkfs.ext4 of /dev/sdN partition 2.
    This creates a completed fat16 partition 1 containing all boot
    files and an empty but properly sized partition 2 rootfs.
    The SD card  partitions are then mounted and rsynced to the
    running system.

    The SD card destination partitions will be mounted on /mnt/clone.
    A log will be written to /var/log/rpi-clone.sh.log.
    Avoid running other disk writing programs when running rpi-clone.sh.

pi@raspberrypi ~/Desktop $ sudo sh rpi-clone.sh -f

usage: rpi-clone.sh sdN {-f|--force-initialize} {-v|--verbose}
    Example:  rpi-clone.sh sda
    -v - list all files as they are copied.
    -f - force initialize the destination partitions

    Clone (rsync) a running Raspberry Pi file system to a destination
    SD card 'sdN' plugged into a Pi USB port (via a USB card reader).
    rpi-clone.sh can clone the running system to a new SD card or can
    incrementally rsync to existing backup Raspberry Pi SD cards.

    If the destination SD card has an existing fat16 partition 1 and a
    ext4 partition 2, rpi-clone.sh assumes (unless using the -f option)
    that the SD card is an existing backup with the partitions
    properly sized and set up for a Raspberry Pi.  All that is needed
    is to mount the partitions and rsync them to the running system.

    If these partitions are not found (or -f), then rpi-clone.sh will ask
    if it is OK to initialize the destination SD card partitions.
    This is done by a partial 'dd' from the running booted device
    /dev/mmcblk0 to the destination SD card /dev/sdN followed by a
    fdisk resize and mkfs.ext4 of /dev/sdN partition 2.
    This creates a completed fat16 partition 1 containing all boot
    files and an empty but properly sized partition 2 rootfs.
    The SD card  partitions are then mounted and rsynced to the
    running system.

    The SD card destination partitions will be mounted on /mnt/clone.
    A log will be written to /var/log/rpi-clone.sh.log.
    Avoid running other disk writing programs when running rpi-clone.sh.

pi@raspberrypi ~/Desktop $ sudo ./rpi-clone.sh -f

usage: rpi-clone.sh sdN {-f|--force-initialize} {-v|--verbose}
    Example:  rpi-clone.sh sda
    -v - list all files as they are copied.
    -f - force initialize the destination partitions

    Clone (rsync) a running Raspberry Pi file system to a destination
    SD card 'sdN' plugged into a Pi USB port (via a USB card reader).
    rpi-clone.sh can clone the running system to a new SD card or can
    incrementally rsync to existing backup Raspberry Pi SD cards.

    If the destination SD card has an existing fat16 partition 1 and a
    ext4 partition 2, rpi-clone.sh assumes (unless using the -f option)
    that the SD card is an existing backup with the partitions
    properly sized and set up for a Raspberry Pi.  All that is needed
    is to mount the partitions and rsync them to the running system.

    If these partitions are not found (or -f), then rpi-clone.sh will ask
    if it is OK to initialize the destination SD card partitions.
    This is done by a partial 'dd' from the running booted device
    /dev/mmcblk0 to the destination SD card /dev/sdN followed by a
    fdisk resize and mkfs.ext4 of /dev/sdN partition 2.
    This creates a completed fat16 partition 1 containing all boot
    files and an empty but properly sized partition 2 rootfs.
    The SD card  partitions are then mounted and rsynced to the
    running system.

    The SD card destination partitions will be mounted on /mnt/clone.
    A log will be written to /var/log/rpi-clone.sh.log.
    Avoid running other disk writing programs when running rpi-clone.sh.

pi@raspberrypi ~/Desktop $ sudo chmod +x rpi-clone.sh
pi@raspberrypi ~/Desktop $ sudo ./rpi-clone.sh -f

usage: rpi-clone.sh sdN {-f|--force-initialize} {-v|--verbose}
    Example:  rpi-clone.sh sda
    -v - list all files as they are copied.
    -f - force initialize the destination partitions

    Clone (rsync) a running Raspberry Pi file system to a destination
    SD card 'sdN' plugged into a Pi USB port (via a USB card reader).
    rpi-clone.sh can clone the running system to a new SD card or can
    incrementally rsync to existing backup Raspberry Pi SD cards.

    If the destination SD card has an existing fat16 partition 1 and a
    ext4 partition 2, rpi-clone.sh assumes (unless using the -f option)
    that the SD card is an existing backup with the partitions
    properly sized and set up for a Raspberry Pi.  All that is needed
    is to mount the partitions and rsync them to the running system.

    If these partitions are not found (or -f), then rpi-clone.sh will ask
    if it is OK to initialize the destination SD card partitions.
    This is done by a partial 'dd' from the running booted device
    /dev/mmcblk0 to the destination SD card /dev/sdN followed by a
    fdisk resize and mkfs.ext4 of /dev/sdN partition 2.
    This creates a completed fat16 partition 1 containing all boot
    files and an empty but properly sized partition 2 rootfs.
    The SD card  partitions are then mounted and rsynced to the
    running system.

    The SD card destination partitions will be mounted on /mnt/clone.
    A log will be written to /var/log/rpi-clone.sh.log.
    Avoid running other disk writing programs when running rpi-clone.sh.

pi@raspberrypi ~/Desktop $ sudo ./rpi-clone.sh sda -f
A destination partition is busy (mounted).  Mount status:
    /dev/sda2:
    /dev/sda1:  /media/BOOT
Aborting!

pi@raspberrypi ~/Desktop $ sudo ./rpi-clone.sh sda -f
A destination partition is busy (mounted).  Mount status:
    /dev/sda2:
    /dev/sda1:  /media/BOOT
Aborting!

pi@raspberrypi ~/Desktop $ unmount sda
-bash: unmount: command not found
pi@raspberrypi ~/Desktop $ umount sda
umount: sda is not mounted (according to mtab)
pi@raspberrypi ~/Desktop $ umount sda2
umount: sda2 is not mounted (according to mtab)
pi@raspberrypi ~/Desktop $ umount sda1
umount: sda1 is not mounted (according to mtab)
pi@raspberrypi ~/Desktop $ sudo ./rpi-clone.sh sda -f
A destination partition is busy (mounted).  Mount status:
    /dev/sda2:
    /dev/sda1:  /media/BOOT
Aborting!

pi@raspberrypi ~/Desktop $
pi@raspberrypi ~/Desktop $ sudo ./rpi-clone.sh sda1 -f

*** Forcing a partition initialization of destination 'sda1' ***
The existing partitions on destination disk 'sda1' are:
Disk /dev/sda1: 15548MB
Partition Table: loop

Number  Start   End      Size     File system  Flags
 1      0.00MB  15548MB  15548MB  fat32

  ... Cannot find a destination boot file system of type: fat16

  ... Cannot find a destination root file system of type: ext4

This script can initialize the destination disk with a partition
structure copied from the currently booted filesytem and then resize
partition 2 (the root filesystem) to use all space on the SD card.
Do you want to initialize the destination /dev/sda1? (yes/no): y

Imaging the partition structure, copying 70 megabytes...
70+0 records in
70+0 records out
73400320 bytes (73 MB) copied, 4.94083 s, 14.9 MB/s
Sizing partition 2 (root partition) to use all SD card space...
mke2fs 1.42.5 (29-Jul-2012)
Could not stat /dev/sda12 --- No such file or directory

The device apparently does not exist; did you specify it correctly?

/dev/sda1 is initialized and resized.  Its partitions are:
Disk /dev/sda1: 15548MB
Partition Table: msdos

Number  Start   End      Size     Type     File system  Flags
 1      4.19MB  62.9MB   58.7MB   primary  fat16        lba
 2      62.9MB  15548MB  15485MB  primary


Your booted /dev/mmcblk0p2 rootfs existing label:
You may enter a label for the destination rootfs /dev/sda12:
e2label: No such file or directory while trying to open /dev/sda12
Couldn't find valid filesystem superblock.

Clone destination disk   :  sda1
Clone destination rootfs :  /dev/sda12 (no label) on /mnt/clone
Clone destination bootfs :  /dev/sda11 on /mnt/clone/boot
Verbose mode             :  off
===============================
Final check, is it Ok to proceed with the clone (yes/no)?: y
=> Mounting /dev/sda12 (no label) on /mnt/clone
mount: special device /dev/sda12 does not exist
Mount failure of /dev/sda12, aborting!

pi@raspberrypi ~/Desktop $ sudo umount /dev/sda1
pi@raspberrypi ~/Desktop $ sudo ./rpi-clone.sh sda -f

*** Forcing a partition initialization of destination 'sda' ***
The existing partitions on destination disk 'sda' are:
Disk /dev/sda: 15552MB
Partition Table: msdos

Number  Start   End      Size     Type     File system  Flags
 1      4.19MB  15552MB  15548MB  primary               lba

  ... Cannot find a destination boot file system of type: fat16

  ... Cannot find a destination root file system of type: ext4

This script can initialize the destination disk with a partition
structure copied from the currently booted filesytem and then resize
partition 2 (the root filesystem) to use all space on the SD card.
Do you want to initialize the destination /dev/sda? (yes/no): y

Imaging the partition structure, copying 70 megabytes...
70+0 records in
70+0 records out
73400320 bytes (73 MB) copied, 4.22976 s, 17.4 MB/s
Sizing partition 2 (root partition) to use all SD card space...
mke2fs 1.42.5 (29-Jul-2012)

/dev/sda is initialized and resized.  Its partitions are:
Disk /dev/sda: 15552MB
Partition Table: msdos

Number  Start   End      Size     Type     File system  Flags
 1      4.19MB  62.9MB   58.7MB   primary  fat16        lba
 2      62.9MB  15552MB  15490MB  primary  ext4


Your booted /dev/mmcblk0p2 rootfs existing label:
You may enter a label for the destination rootfs /dev/sda2:

Clone destination disk   :  sda
Clone destination rootfs :  /dev/sda2 (no label) on /mnt/clone
Clone destination bootfs :  /dev/sda1 on /mnt/clone/boot
Verbose mode             :  off
===============================
Final check, is it Ok to proceed with the clone (yes/no)?: y
=> Mounting /dev/sda2 (no label) on /mnt/clone
=> Mounting /dev/sda1 on /mnt/clone/boot
===============================
Starting the filesystem rsync to sda
(This may take several minutes)...



暧昧贴

发表评论

    微笑 大笑 拽 大哭 奸笑 流汗 喷血 生气 囧 不爽 晕 示爱 卖萌 吃惊 迷离 爱你 吓死了 呵呵

      已有3条评论

    1. avatar cdog#Sofa
      系统复制么。。。
      看得出过程非常艰辛2333
      2015-02-15 23:46回复我是沙发!
      1. avatarCC
        回复了cdog:被发现了......主要是不熟练啊.....应该说半年前同样做过这样的事,当时比现在要熟练好多呢...... 2015-02-16 02:03回复 求知若饥,虚心若愚。
      2. avatarCC
        回复了cdog:其实吧,还包括装蓝牙驱动,音乐播放器什么的...... 2015-02-16 02:10回复 求知若饥,虚心若愚。